FANDOM


  • Okey.---- Minecraft Crash Report ----
    // I just don't know what went wrong :(

    Time: 7/27/16 7:54 AM
    Description: Registering texture

    java.lang.NullPointerException: Registering texture
    at shadersmodcore.client.ShadersTex.getNSMapLocation(ShadersTex.java:847)
    at shadersmodcore.client.ShadersTex.loadNSMap(ShadersTex.java:856)
    at shadersmodcore.client.ShadersTex.loadAtlasSprite(ShadersTex.java:1005)
    at net.minecraft.client.renderer.texture.TextureAtlasSprite.func_147964_a(TextureAtlasSprite.java:265)
    at lotr.client.render.LOTRConnectedTextures$BufferedImageIcon.load(LOTRConnectedTextures.java:541)
    at net.minecraft.client.renderer.texture.TextureMap.func_110571_b(TextureMap.java:187)
    at net.minecraft.client.renderer.texture.TextureMap.func_110551_a(TextureMap.java:136)
    at net.minecraft.client.renderer.texture.TextureManager.func_110579_a(TextureManager.java:94)
    at net.minecraft.client.renderer.texture.TextureManager.func_110549_a(TextureManager.java:204)
    at net.minecraft.client.resources.SimpleReloadableResourceManager.func_110544_b(SimpleReloadableResourceManager.java:143)
    at net.minecraft.client.resources.SimpleReloadableResourceManager.func_110541_a(SimpleReloadableResourceManager.java:121)
    at net.minecraft.client.Minecraft.func_110436_a(Minecraft.java:617)
    at cpw.mods.fml.client.FMLClientHandler.finishMinecraftLoading(FMLClientHandler.java:327)
    at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:552)
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:878)
    at net.minecraft.client.main.Main.main(SourceFile:148)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:483)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)


    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------

    -- Head --
    Stacktrace:
    at shadersmodcore.client.ShadersTex.getNSMapLocation(ShadersTex.java:847)
    at shadersmodcore.client.ShadersTex.loadNSMap(ShadersTex.java:856)
    at shadersmodcore.client.ShadersTex.loadAtlasSprite(ShadersTex.java:1005)
    at net.minecraft.client.renderer.texture.TextureAtlasSprite.func_147964_a(TextureAtlasSprite.java:265)
    at lotr.client.render.LOTRConnectedTextures$BufferedImageIcon.load(LOTRConnectedTextures.java:541)
    at net.minecraft.client.renderer.texture.TextureMap.func_110571_b(TextureMap.java:187)
    at net.minecraft.client.renderer.texture.TextureMap.func_110551_a(TextureMap.java:136)

    -- Resource location being registered --
    Details:
    Resource location: minecraft:textures/atlas/blocks.png
    Texture object class: net.minecraft.client.renderer.texture.TextureMap
    Stacktrace:
    at net.minecraft.client.renderer.texture.TextureManager.func_110579_a(TextureManager.java:94)
    at net.minecraft.client.renderer.texture.TextureManager.func_110549_a(TextureManager.java:204)
    at net.minecraft.client.resources.SimpleReloadableResourceManager.func_110544_b(SimpleReloadableResourceManager.java:143)
    at net.minecraft.client.resources.SimpleReloadableResourceManager.func_110541_a(SimpleReloadableResourceManager.java:121)
    at net.minecraft.client.Minecraft.func_110436_a(Minecraft.java:617)
    at cpw.mods.fml.client.FMLClientHandler.finishMinecraftLoading(FMLClientHandler.java:327)
    at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:552)

    -- Initialization --
    Details:
    Stacktrace:
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:878)
    at net.minecraft.client.main.Main.main(SourceFile:148)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:483)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

    -- System Details --
    Details:
    Minecraft Version: 1.7.10
    Operating System: Windows 10 (amd64) version 10.0
    Java Version: 1.8.0_25, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 501144416 bytes (477 MB) / 1239314432 bytes (1181 MB) up to 3207856128 bytes (3059 MB)
    JVM Flags: 6 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx3G -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn128M
    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    FML: MCP v9.05 FML v7.10.99.99 Minecraft Forge 10.13.4.1558 Optifine OptiFine_1.7.10_HD_U_D6 7 mods loaded, 7 mods active
    States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
    UCHIJA mcp{9.05} [Minecraft Coder Pack] (minecraft.jar)
    UCHIJA FML{7.10.99.99} [Forge Mod Loader] (forge-1.7.10-10.13.4.1558-1.7.10.jar)
    UCHIJA Forge{10.13.4.1558} [Minecraft Forge] (forge-1.7.10-10.13.4.1558-1.7.10.jar)
    UCHIJA lotr{Beta v28.2 for Minecraft 1.7.10} [The Lord of the Rings Mod] ([1.7.10] The Lord of the Rings Mod B28.2.jar)
    UCHIJA hud{1.3.5} [Better HUD] (Better HUD by NukeDuck [1.7.10][1.3.5].jar)
    UCHIJA buildhelper{1.0.0} [Build Helper] (BuildHelper_v1.0.0.jar)
    UCHIJA moreplayermodels{1.7.10b} [MorePlayerModels] (More-Player-Models-2-Mod-1.7.10.jar)
    GL info: ' Vendor: 'Intel' Version: '4.4.0 - Build 21.20.16.4471' Renderer: 'Intel(R) HD Graphics 520'
    Launched Version: 1.7.10-Forge10.13.4.1558-1.7.10
    LWJGL: 2.9.1
    OpenGL: Intel(R) HD Graphics 520 GL version 4.4.0 - Build 21.20.16.4471, Intel
    GL Caps: Using GL 1.3 multitexturing.
    Using framebuffer objects because OpenGL 3.0 is supported and separate blending is supported.
    Anisotropic filtering is supported and maximum anisotropy is 16.
    Shaders are available because OpenGL 2.1 is supported.

    Is Modded: Definitely; Client brand changed to 'fml,forge'
    Type: Client (map_client.txt)
    Resource Packs: []
    Current Language: English (US)
    Profiler Position: N/A (disabled)
    Vec3 Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    Anisotropic Filtering: Off (1)
    OptiFine Version: OptiFine_1.7.10_HD_U_D6
    Render Distance Chunks: 12
    Mipmaps: 4
    Anisotropic Filtering: 1
    Antialiasing: 0
    Multitexture: false
    OpenGlVersion: 4.4.0 - Build 21.20.16.4471
    OpenGlRenderer: Intel(R) HD Graphics 520
    OpenGlVendor: Intel
    CpuCount: 4

    That is my crash report. I was trying to use GLL Shaders and it crashed my game. I am currently not using fastcraft, in fact I am using optifine, but I proved that wasnt the issue, I think. I trided adding ram, but it made no difference. Optifine 1.8.9 worked well with lite shaders on my computer, so I think it shouold be working. Please help, Lee5589 aka Lord_Mithalvaiel.

      Loading editor
    • Update, I tried launching minecraft without the other mods (i had lotr, opti, and glsl on only when I tried), but it still crashed.

        Loading editor
    • If the shaders mod altered the clouds, that might be the problem. And remove optifine, it causes problems.

        Loading editor
    • err, I just have the mod that allows for shaders, and the comp page says it is fine and good usually. I havent applied a shader yet, but I would like a coud tutorial because I dont get ur statement if I ever get it working please. About optifine, i tried using it with and without the shaders. Nothing happened. Glsl shaders cant use fastcraft which is my go to lag reduction and fps increaser, so I need optifine.

        Loading editor
    • Still wont work. QUitting at the same time every time.

        Loading editor
    • On the mod compatibilities page, it says that optifine causes crashes.

        Loading editor
    • Direranger50 wrote:
      On the mod compatibilities page, it says that optifine causes crashes.


      Even with or without optifine my game crashes basically at the same spot when I try and use shaders mod

        Loading editor
    • Then the shaders mod is causing problems. You have to remove it.

        Loading editor
    • Direranger50 wrote:
      Then the shaders mod is causing problems. You have to remove it.


      Well there are people who still can use it so there must be something i'm doing that isn't compatible perhaps?

        Loading editor
    • It could be the forge version or a config setting, I think.

        Loading editor
    • Direranger50 wrote:
      It could be the forge version or a config setting, I think.


      Well i messed with the lotr config settings and nothing changed

        Loading editor
    • I don't know what it is. It's something behind the scenes that I can't identify. Ask someone that understands this stuff more.

        Loading editor
    • Raiden Rex wrote:
      Direranger50 wrote:
      Then the shaders mod is causing problems. You have to remove it.

      Well there are people who still can use it so there must be something i'm doing that isn't compatible perhaps?

      How do you know other people can still use it? Have you talked to someone who is using it?

        Loading editor
    • MilkMC wrote:
      Raiden Rex wrote:
      Direranger50 wrote:
      Then the shaders mod is causing problems. You have to remove it.

      Well there are people who still can use it so there must be something i'm doing that isn't compatible perhaps?
      How do you know other people can still use it? Have you talked to someone who is using it?

      Because if this thread http://lotrminecraftmod.wikia.com/wiki/Thread:239802

      Also this image
      2016-05-10 01.12.04

      Shaders

      Which has dried reed plants which were added in beta 28


      + Added dried reed plants
      
        Loading editor
    • Raiden Rex wrote:
      MilkMC wrote:
      Raiden Rex wrote:
      Direranger50 wrote:
      Then the shaders mod is causing problems. You have to remove it.

      Well there are people who still can use it so there must be something i'm doing that isn't compatible perhaps?
      How do you know other people can still use it? Have you talked to someone who is using it?
      Because if this thread http://lotrminecraftmod.wikia.com/wiki/Thread:239802
      Also this image
      2016-05-10 01.12.04

      Shaders

      Which has dried reed plants which were added in beta 28


      + Added dried reed plants
      

      I read the thread you mentioned and it peaked my curiosity, so I decided to try the shaders for myself. Much to my dismay, it caused my game to crash. Eventually, I removed every mod except for the shaders and it still crashed. I have never used shaders before, so its possible that I am just doing something wrong. Now I am just wondering if you and Lee are able to get the shaders working without any other mods at all.

        Loading editor
    • I was never able to get shaders working for me. It always results in extreme framerate drops and crashes. I guess they are just too demanding for my computers.


        Loading editor
    • MilkMC wrote:
      Raiden Rex wrote:
      MilkMC wrote:
      Raiden Rex wrote:
      Direranger50 wrote:
      Then the shaders mod is causing problems. You have to remove it.

      Well there are people who still can use it so there must be something i'm doing that isn't compatible perhaps?
      How do you know other people can still use it? Have you talked to someone who is using it?
      Because if this thread http://lotrminecraftmod.wikia.com/wiki/Thread:239802
      Also this image
      2016-05-10 01.12.04

      Shaders

      Which has dried reed plants which were added in beta 28


      + Added dried reed plants
      
      I read the thread you mentioned and it peaked my curiosity, so I decided to try the shaders for myself. Much to my dismay, it caused my game to crash. Eventually, I removed every mod except for the shaders and it still crashed. I have never used shaders before, so its possible that I am just doing something wrong. Now I am just wondering if you and Lee are able to get the shaders working without any other mods at all.


      Without the Lord of the rings mod I can run shaders fine. But when i add the lotr mod it crashes, and if I use the lotr mod with optifine or without it, it works fine

        Loading editor
    • err i dont even have the shaderpack. the mod that allows me to use shaders doesnt work, yet it does work in vanilla.

        Loading editor
    • Lee5589 wrote:
      err i dont even have the shaderpack. the mod that allows me to use shaders doesnt work, yet it does work in vanilla

      Well, the crash is a confilict between lotr and the shaders mod not a shaderpack :p

        Loading editor
    • If only one of the developers could help us :\

        Loading editor
    • Lee5589 wrote:
      Okey.---- Minecraft Crash Report ----
      // I just don't know what went wrong :(

      Time: 7/27/16 7:54 AM
      Description: Registering texture

      java.lang.NullPointerException: Registering texture
      at shadersmodcore.client.ShadersTex.getNSMapLocation(ShadersTex.java:847)
      at shadersmodcore.client.ShadersTex.loadNSMap(ShadersTex.java:856)
      at shadersmodcore.client.ShadersTex.loadAtlasSprite(ShadersTex.java:1005)
      at net.minecraft.client.renderer.texture.TextureAtlasSprite.func_147964_a(TextureAtlasSprite.java:265)
      at lotr.client.render.LOTRConnectedTextures$BufferedImageIcon.load(LOTRConnectedTextures.java:541)
      at net.minecraft.client.renderer.texture.TextureMap.func_110571_b(TextureMap.java:187)
      at net.minecraft.client.renderer.texture.TextureMap.func_110551_a(TextureMap.java:136)
      at net.minecraft.client.renderer.texture.TextureManager.func_110579_a(TextureManager.java:94)
      at net.minecraft.client.renderer.texture.TextureManager.func_110549_a(TextureManager.java:204)
      at net.minecraft.client.resources.SimpleReloadableResourceManager.func_110544_b(SimpleReloadableResourceManager.java:143)
      at net.minecraft.client.resources.SimpleReloadableResourceManager.func_110541_a(SimpleReloadableResourceManager.java:121)
      at net.minecraft.client.Minecraft.func_110436_a(Minecraft.java:617)
      at cpw.mods.fml.client.FMLClientHandler.finishMinecraftLoading(FMLClientHandler.java:327)
      at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:552)
      at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:878)
      at net.minecraft.client.main.Main.main(SourceFile:148)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:483)
      at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
      at net.minecraft.launchwrapper.Launch.main(Launch.java:28)


      A detailed walkthrough of the error, its code path and all known details is as follows:
      ---------------------------------------------------------------------------------------

      -- Head --
      Stacktrace:
      at shadersmodcore.client.ShadersTex.getNSMapLocation(ShadersTex.java:847)
      at shadersmodcore.client.ShadersTex.loadNSMap(ShadersTex.java:856)
      at shadersmodcore.client.ShadersTex.loadAtlasSprite(ShadersTex.java:1005)
      at net.minecraft.client.renderer.texture.TextureAtlasSprite.func_147964_a(TextureAtlasSprite.java:265)
      at lotr.client.render.LOTRConnectedTextures$BufferedImageIcon.load(LOTRConnectedTextures.java:541)
      at net.minecraft.client.renderer.texture.TextureMap.func_110571_b(TextureMap.java:187)
      at net.minecraft.client.renderer.texture.TextureMap.func_110551_a(TextureMap.java:136)

      -- Resource location being registered --
      Details:
      Resource location: minecraft:textures/atlas/blocks.png
      Texture object class: net.minecraft.client.renderer.texture.TextureMap
      Stacktrace:
      at net.minecraft.client.renderer.texture.TextureManager.func_110579_a(TextureManager.java:94)
      at net.minecraft.client.renderer.texture.TextureManager.func_110549_a(TextureManager.java:204)
      at net.minecraft.client.resources.SimpleReloadableResourceManager.func_110544_b(SimpleReloadableResourceManager.java:143)
      at net.minecraft.client.resources.SimpleReloadableResourceManager.func_110541_a(SimpleReloadableResourceManager.java:121)
      at net.minecraft.client.Minecraft.func_110436_a(Minecraft.java:617)
      at cpw.mods.fml.client.FMLClientHandler.finishMinecraftLoading(FMLClientHandler.java:327)
      at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:552)

      -- Initialization --
      Details:
      Stacktrace:
      at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:878)
      at net.minecraft.client.main.Main.main(SourceFile:148)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:483)
      at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
      at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

      -- System Details --
      Details:
      Minecraft Version: 1.7.10
      Operating System: Windows 10 (amd64) version 10.0
      Java Version: 1.8.0_25, Oracle Corporation
      Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
      Memory: 501144416 bytes (477 MB) / 1239314432 bytes (1181 MB) up to 3207856128 bytes (3059 MB)
      JVM Flags: 6 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx3G -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn128M
      AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
      IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
      FML: MCP v9.05 FML v7.10.99.99 Minecraft Forge 10.13.4.1558 Optifine OptiFine_1.7.10_HD_U_D6 7 mods loaded, 7 mods active
      States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
      UCHIJA mcp{9.05} [Minecraft Coder Pack] (minecraft.jar)
      UCHIJA FML{7.10.99.99} [Forge Mod Loader] (forge-1.7.10-10.13.4.1558-1.7.10.jar)
      UCHIJA Forge{10.13.4.1558} [Minecraft Forge] (forge-1.7.10-10.13.4.1558-1.7.10.jar)
      UCHIJA lotr{Beta v28.2 for Minecraft 1.7.10} [The Lord of the Rings Mod] ([1.7.10] The Lord of the Rings Mod B28.2.jar)
      UCHIJA hud{1.3.5} [Better HUD] (Better HUD by NukeDuck [1.7.10][1.3.5].jar)
      UCHIJA buildhelper{1.0.0} [Build Helper] (BuildHelper_v1.0.0.jar)
      UCHIJA moreplayermodels{1.7.10b} [MorePlayerModels] (More-Player-Models-2-Mod-1.7.10.jar)
      GL info: ' Vendor: 'Intel' Version: '4.4.0 - Build 21.20.16.4471' Renderer: 'Intel(R) HD Graphics 520'
      Launched Version: 1.7.10-Forge10.13.4.1558-1.7.10
      LWJGL: 2.9.1
      OpenGL: Intel(R) HD Graphics 520 GL version 4.4.0 - Build 21.20.16.4471, Intel
      GL Caps: Using GL 1.3 multitexturing.
      Using framebuffer objects because OpenGL 3.0 is supported and separate blending is supported.
      Anisotropic filtering is supported and maximum anisotropy is 16.
      Shaders are available because OpenGL 2.1 is supported.

      Is Modded: Definitely; Client brand changed to 'fml,forge'
      Type: Client (map_client.txt)
      Resource Packs: []
      Current Language: English (US)
      Profiler Position: N/A (disabled)
      Vec3 Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
      Anisotropic Filtering: Off (1)
      OptiFine Version: OptiFine_1.7.10_HD_U_D6
      Render Distance Chunks: 12
      Mipmaps: 4
      Anisotropic Filtering: 1
      Antialiasing: 0
      Multitexture: false
      OpenGlVersion: 4.4.0 - Build 21.20.16.4471
      OpenGlRenderer: Intel(R) HD Graphics 520
      OpenGlVendor: Intel
      CpuCount: 4

      That is my crash report. I was trying to use GLL Shaders and it crashed my game. I am currently not using fastcraft, in fact I am using optifine, but I proved that wasnt the issue, I think. I trided adding ram, but it made no difference. Optifine 1.8.9 worked well with lite shaders on my computer, so I think it shouold be working. Please help, Lee5589 aka Lord_Mithalvaiel.

      What is your GPU btw?

        Loading editor
    • This looks to be caused by the LOTR mod's custom gate texture generation. There is nothing in the vanilla-Forge code that would seem to cause this crash, though. It may be that the shaders mod alters vanilla code, and if so it may be that this is not easily fixable, if at all. Send me a link to the mod in question and I will have a look.

        Loading editor
    • LOTRMod wrote:
      This looks to be caused by the LOTR mod's custom gate texture generation. There is nothing in the vanilla-Forge code that would seem to cause this crash, though. It may be that the shaders mod alters vanilla code, and if so it may be that this is not easily fixable, if at all. Send me a link to the mod in question and I will have a look.


      Thank you for your help, here is the forum page and here is the latest version for 1.7.10.

        Loading editor
    • plz help mevans

        Loading editor
    • A FANDOM user
        Loading editor
Give Kudos to this message
You've given this message Kudos!
See who gave Kudos to this message
Community content is available under CC-BY-SA unless otherwise noted.