FANDOM


  • i'm using the latest version of the mod (beta 34.1) and forge 10.13.4.1558 1.7.10

    the game crash only when i try to load my world (where i have pretty advanced stuff), out of that the game works fine

    here is the latest crash report, any help will be grateful, because i search in many forums a solution but none of these fixed it

    sorry for my english

    crash report:


    Minecraft Crash Report ----
    // Who set us up the TNT?

    Time: 7/09/18 17:24
    Description: Exception in server tick loop

    java.lang.ArrayIndexOutOfBoundsException: -112
     at net.minecraft.world.chunk.NibbleArray.func_76582_a(SourceFile:26)
     at net.minecraft.world.chunk.storage.ExtendedBlockStorage.func_76665_b(SourceFile:75)
     at net.minecraft.world.chunk.Chunk.func_76628_c(Chunk.java:548)
     at net.minecraft.world.chunk.Chunk.func_150812_a(Chunk.java:878)
     at net.minecraft.world.chunk.Chunk.func_150813_a(Chunk.java:862)
     at net.minecraft.world.chunk.storage.AnvilChunkLoader.loadEntities(AnvilChunkLoader.java:500)
     at net.minecraftforge.common.chunkio.ChunkIOProvider.callStage2(ChunkIOProvider.java:41)
     at net.minecraftforge.common.chunkio.ChunkIOProvider.callStage2(ChunkIOProvider.java:12)
     at net.minecraftforge.common.util.AsynchronousExecutor$Task.finish(AsynchronousExecutor.java:189)
     at net.minecraftforge.common.util.AsynchronousExecutor.finishActive(AsynchronousExecutor.java:354)
     at net.minecraftforge.common.chunkio.ChunkIOExecutor.tick(ChunkIOExecutor.java:30)
     at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:596)
     at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:547)
     at net.minecraft.server.integrated.IntegratedServer.func_71217_p(IntegratedServer.java:111)
     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:396)
     at net.minecraft.server.MinecraftServer$2.run(MinecraftServer.java:685)


    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------

    -- System Details --
    Details:
     Minecraft Version: 1.7.10
     Operating System: Windows 7 (amd64) version 6.1
     Java Version: 1.7.0_72, Oracle Corporation
     Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
     Memory: 400361504 bytes (381 MB) / 1288699904 bytes (1229 MB) up to 1908932608 bytes (1820 MB)
     JVM Flags: 2 total; -Xmx2G -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump
     AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
     IntCache: cache: 13, tcache: 0, allocated: 13, tallocated: 95
     FML: MCP v9.05 FML v7.10.99.99 Minecraft Forge 10.13.4.1558 5 mods loaded, 5 mods active
     States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
     UCHIJAAAA    mcp{9.05} [Minecraft Coder Pack] (minecraft.jar) 
     UCHIJAAAA    FML{7.10.99.99} [Forge Mod Loader] (forge-1.7.10-10.13.4.1558-1.7.10.jar) 
     UCHIJAAAA    Forge{10.13.4.1558} [Minecraft Forge] (forge-1.7.10-10.13.4.1558-1.7.10.jar) 
     UCHIJAAAA    FastCraft{1.25} [FastCraft] (fastcraft-1.25.jar) 
     UCHIJAAAA    lotr{Update v34.0 for Minecraft 1.7.10} [The Lord of the Rings Mod] (LOTRMod v34.0.jar) 
     GL info: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.
     Profiler Position: N/A (disabled)
     Vec3 Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
     Player Count: 1 / 8; [EntityPlayerMP['yako'/202, l='tierra mediaaa', x=98692,31, y=74,48, z=112419,75]]
     Type: Integrated Server (map_client.txt)
     Is Modded: Definitely; Client brand changed to 'fml,forge'

      Loading editor
    • I think your world is corrupted. Not sure if it is just partially corrupted or if it is the whole world.

      I'd be willing to diagnose the issue further if you could zip and upload a copy of your save file.

      MilkBucket MilkMC Try restarting your game, Fandom User.MilkBucket

        Loading editor
    • how can i send you the zip file?, you need the whole world file?, or you only need the data files or something?, i don't know :(

        Loading editor
    • The whole thing if it's not too big. Use mediafire or a similar website to upload it. If it is too big, here is a list of files (prefixed by their path) that should probably be enough to find the issue:
      /tierra mediaaa/MiddleEarth/region/r.192.219.mca
      /tierra mediaaa/MiddleEarth/region/r.193.219.mca
      /tierra mediaaa/level.dat
      /tierra mediaa/playerdata/835cb8bb-833c-4621-aca6-ba21eb529fb5.dat

      MilkBucket MilkMC Have a chat with me, Fandom User.MilkBucket

        Loading editor
    • Way to go Milk, using Unix-style paths :P

      SamwiseFilmore
        Loading editor
    • Oh, I forgot window does backslashes. I've used it so much on Ubuntu that I just did it like that without even thinking about it :P

      MilkBucket MilkMC Send me a message, Fandom User.MilkBucket

        Loading editor
    • hi, here is the link, it`s 1,84gb, if it is not too big, i hope it works

      [[1]]

        Loading editor
    • ok, i'm seeing that it's too much, so here is the archives you tell me

      [[1]]

        Loading editor
    • You had 10 corrupted chunks. Luckily none of them were in your base.
      Tierra mediaaa

      Overhead view of your base. A black star signifies a corrupted chunk.

      I first corrected the positions of your corrupted chunks so that I could actually log in without crashing. Then, I deleted the corrupted chunks so that the correct terrain will generate there.

      Here is the file I edited. Just go to
      /tierra mediaaa/MiddleEarth/region/
      and replace the corrupted file with this one and you'll be able to play again.

      MilkBucket MilkMC Ask me a question, Fandom User.MilkBucket

        Loading editor
    • IT WORKS Thank you so much, really

      Finally, what would be the cause of these corrupt chunks?

        Loading editor
    • Hard to say for sure, but my guess would be your world was closed before it had a change to properly save everything.

      MilkBucket MilkMC Check your render distance, Fandom User!MilkBucket

        Loading editor
    • Como hiciste todo eso? tengo exactamente el mismo problema y me gustaria poder eliminar las zonas que me estan causando problemas, de hecho ni siquiera me deja entrar .MilkMC escribió:
      Tenías 10 trozos corruptos. Afortunadamente ninguno de ellos estaba en tu base.
      Tierra mediaaa

      Overhead view of your base. A black star signifies a corrupted chunk.

      Primero corregí las posiciones de tus fragmentos corruptos para poder iniciar sesión sin fallar. Luego, eliminé los fragmentos corruptos para que se genere el terreno correcto allí.

      Here está el archivo que he editado. Solo ve a
      
      /tierra mediaaa/MiddleEarth/region/
      y reemplace el archivo dañado con este y podrá volver a jugar.
      Empty
      MilkSig2
      Have some candy!
      MilkSig3
      MilkBucket

      MilkMC

      Have a chat with me, Fandom User.MilkBucket
        Loading editor
    • This is a tutorial on how to fix/remove corrupted chunks. If you find this complicated, please take a backup of your world before starting and/or contact MilkMC for help before proceeding.

      Locating the affected chunk(s)

      This will be easiest if you can still access the area around the affected chunk(s). Ideally, you'll want to fly into the affected chunk and get coordinates for it. If you can't get close to it, try using a mini-map to provide the coordinates of that chunk. Once you have the coordinates, use this tool to identify which region file contains it and the chunk information for it. I prefer to copy the region file from
      /.minecraft/saves/<name of your world>/MiddleEarth/region/
      somewhere else more easily accessible to work on it.

      Using NBT Explorer

      This next part will require the use of an NBT Editor. For this tutorial it is assumed you'll be using NBT Explorer.

      Open NBT Explorer and navigate to the location of the region file you identified above. Click the plus sign to expand the contents of the region file. Use the chunk information you found earlier to go to the affected chunk and expand it as well as the Level field. Next, confirm that you located the right chunk. To do this, look at xPos and zPos and compare them to where it says in world at (X, Z). If the first set of numbers don't match the other set, then you found the right chunk. Now you can click on that chunk and press delete. Save the file and put it back where you got it from (if you moved it).

      Launch Minecraft

      Now launch Minecraft and confirm what you did worked. If you have a lot of duplicate entities, try leaving the area and coming back. That should make them despawn, unless they don't despawn naturally, in which case you'll have to find a where to kill/remove them.

      MilkBucket MilkMC Have a chat with me, Fandom User.MilkBucket

        Loading editor
    • A FANDOM user
        Loading editor
Give Kudos to this message
You've given this message Kudos!
See who gave Kudos to this message
Community content is available under CC-BY-SA unless otherwise noted.