FANDOM


  • MilkMC
    MilkMC closed this thread because:
    Necroposting
    18:41, August 2, 2017

    Already posted my problem in wiki page comments (http://lotrminecraftmod.wikia.com/wiki/Hiring) Probably that place wasn't a right one. Sorry for that.

    I'm playing mod version beta 23.3 and I cannot command my hired unit.

    Ocassionally while pushing buttons I have hired one Hobbit Shirriff. Now I want let him stay and not follow me. Wiki says: "right-click them and click command button". I do right-click but not see any buttons, GUI not appears. In case of Traders right-clicking works (brings menu). What I'm doing wrong?


    Also mentioned that hired Hobbit Shirriff spawned and follows me, but I see neither 'Hired' tag above his head nor health bar.

      Loading editor
    • Try using a Horn of Command -- Halt Units. You can make this out of three bronze ingots. Then, blow this horn to halt your unit.

      Anduril Glflegolas (admin) Send a Messenger 19:23, May 2, 2015 (UTC)

        Loading editor
    • I was going to say that but would he be able to assign his unit to a squadron if he can't right-click it?

        Loading editor
    • Thanks, Horn of Command worked! Now that poor hobbit stands like cursed... but let it be... not follows me like mad everywere I go.

      But meanwhile I hired 3 more of them to test whether this was a glitch with a that one and also assigned them to a squadron upon hiring in Hiring menu. So Table of Command was necessary to stop them all.

      You came in time - I was about abandon my game and start a new one.

      But ... should it be a gui upon right-clicking a hired unit or I should carefully assign them to squadrons upon hiring and stop/follow them by the Horn of Command?

        Loading editor
    • I have same problem here, i cant command hired units in MP, but i SP im all works good. We've installed same versions of forge so, what kind of problem can be there?

        Loading editor
    • Problem continues with beta 27.2 (Forge version 10.13.3..1428). SP works fine.  MP there is no command GUI when right-clicking on the unit; nor any "Hired" tag above the unit's head.  Squadron based horns do work, but since there's no way to assign to a squadron after purchase that has limited application.

        Loading editor
    • The "Hired" tag has been removed in Beta 26. Now hired units only display their healthbar and the weapon they're holding.

      Are there any other mods on this server other than LotR?

      11:17, March 13, 2016 (UTC)
        Loading editor
    • I just retested and confirmed.  No mods installed on the server side and only Journeymap (JourneyMap5.0.1_Unlimited_MC1.7.10) on the client side.  No health-bar across the top of the unit and right-clicking does nothing.  Also went back into a SP game - health-bar visible & right click brings up the command window.

        Loading editor
    • In that case, I might suggest backing up your worlds, deleting your .minecraft, and reinstalling Minecraft, Forge, and the LotR Mod. Perhaps something got corrupted in there. If that still doesn't solve your problem, I'd check with the server owner.

      10:58, March 17, 2016 (UTC)
        Loading editor
    • I am the server owner. :)  You believe this is a client-side problem then?

        Loading editor
    • It probably is a client-side problem.

      22:33, March 18, 2016 (UTC)
        Loading editor
    • It's been a while since I've been able to work on this issue but I finally found time, and a resolution.  This is/was decidedly a server-side problem.  I was able to create a working LOTR multi-player world by using the recommended version of Forge - 1291.  That's a rather old version of Forge.  I have not tried all versions since then, but it did not work for me with either 1428 or 1558. 

      It would be nice to know if there are other known good versions of Forge.  If anyone has a list, please share.

      Thanks.

        Loading editor
    • I run version .1240, and everything seems to be okay.

      12:36, December 8, 2016 (UTC)
        Loading editor
    • Thank you Glflegolas.  That would be an older version than 1291. I should have been clearer that I was looking for newer (my bad). :)  I wonder if something "broke" after 1291?

        Loading editor
    • I am not entirely sure, it might be true.

      17:13, December 8, 2016 (UTC)
        Loading editor
    • Once again a very late reply, but at least we have a root cause.  It turns out that the game must be in "Online mode" (server.properties: online-mode=true).  As soon as we changed that parameter to 'false' it broke.  Switched it back to 'true' it started working again.

      I'll leave it to the experts to figure out whether that's a bug or a feature. :)

      Thanks for the help!

        Loading editor
    • I have the same problem

        Loading editor
Give Kudos to this message
You've given this message Kudos!
See who gave Kudos to this message
Community content is available under CC-BY-SA unless otherwise noted.