FANDOM


(Created page with "But now, every time I try to run the game in Eclipse with the launch configuration pointing to my coremod, I get a NoClassDefFoundError for the Mod Container class. Did you ev...")
 
 
Line 1: Line 1:
 
But now, every time I try to run the game in Eclipse with the launch configuration pointing to my coremod, I get a NoClassDefFoundError for the Mod Container class. Did you ever experience this?
 
But now, every time I try to run the game in Eclipse with the launch configuration pointing to my coremod, I get a NoClassDefFoundError for the Mod Container class. Did you ever experience this?
  +
  +
To elaborate: the no class error is for net.minecraftforge.gradle.GradleStartCommon$AccessTransformerTransformer:
  +
<code>java.lang.ClassNotFoundException: net.minecraftforge.gradle.GradleStartCommon$AccessTransformerTransformer
  +
at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:191) ~[launchwrapper-1.11.jar:?]
  +
at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_45]
  +
at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_45]
  +
at net.minecraft.launchwrapper.LaunchClassLoader.registerTransformer(LaunchClassLoader.java:88) [launchwrapper-1.11.jar:?]
  +
at net.minecraftforge.gradle.tweakers.AccessTransformerTweaker.injectIntoClassLoader(Unknown Source) [start/:?]
  +
at net.minecraft.launchwrapper.Launch.launch(Launch.java:115) [launchwrapper-1.11.jar:?]
  +
at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.11.jar:?]
  +
at net.minecraftforge.gradle.GradleStartCommon.launch(Unknown Source) [start/:?]
  +
at GradleStart.main(Unknown Source) [start/:?]
  +
Caused by: java.lang.NullPointerException
  +
at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:182) ~[launchwrapper-1.11.jar:?]
  +
... 8 more</code>
  +
  +
and shortly after, the actual Main class fails to load:
  +
  +
<code>Unable to launch
  +
java.lang.ClassNotFoundException: net.minecraft.client.main.Main
  +
at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:191) ~[launchwrapper-1.11.jar:?]
  +
at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_45]
  +
at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_45]
  +
at java.lang.Class.forName0(Native Method) ~[?:1.8.0_45]
  +
at java.lang.Class.forName(Unknown Source) ~[?:1.8.0_45]
  +
at net.minecraft.launchwrapper.Launch.launch(Launch.java:131) [launchwrapper-1.11.jar:?]
  +
at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.11.jar:?]
  +
at net.minecraftforge.gradle.GradleStartCommon.launch(Unknown Source) [start/:?]
  +
at GradleStart.main(Unknown Source) [start/:?]
  +
Caused by: java.lang.NullPointerException
  +
at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:182) ~[launchwrapper-1.11.jar:?]
  +
... 8 more</code>
  +
  +
I would have thought it was just a broken build, and tried refreshing the project (and I did) - except that, if I remove the coremod from my launch configuration, everything starts fine. So it cannot be a broken build or missing file, it must be something wrong with the coremod.
  +
  +
The launch argument I used is <code>-Dfml.coreMods.load=lotr.common.coremod.LOTRLoadingPlugin</code>

Latest revision as of 02:14, April 2, 2017

But now, every time I try to run the game in Eclipse with the launch configuration pointing to my coremod, I get a NoClassDefFoundError for the Mod Container class. Did you ever experience this?

To elaborate: the no class error is for net.minecraftforge.gradle.GradleStartCommon$AccessTransformerTransformer: java.lang.ClassNotFoundException: net.minecraftforge.gradle.GradleStartCommon$AccessTransformerTransformer at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:191) ~[launchwrapper-1.11.jar:?] at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_45] at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_45] at net.minecraft.launchwrapper.LaunchClassLoader.registerTransformer(LaunchClassLoader.java:88) [launchwrapper-1.11.jar:?] at net.minecraftforge.gradle.tweakers.AccessTransformerTweaker.injectIntoClassLoader(Unknown Source) [start/:?] at net.minecraft.launchwrapper.Launch.launch(Launch.java:115) [launchwrapper-1.11.jar:?] at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.11.jar:?] at net.minecraftforge.gradle.GradleStartCommon.launch(Unknown Source) [start/:?] at GradleStart.main(Unknown Source) [start/:?] Caused by: java.lang.NullPointerException at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:182) ~[launchwrapper-1.11.jar:?] ... 8 more

and shortly after, the actual Main class fails to load:

Unable to launch java.lang.ClassNotFoundException: net.minecraft.client.main.Main at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:191) ~[launchwrapper-1.11.jar:?] at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_45] at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_45] at java.lang.Class.forName0(Native Method) ~[?:1.8.0_45] at java.lang.Class.forName(Unknown Source) ~[?:1.8.0_45] at net.minecraft.launchwrapper.Launch.launch(Launch.java:131) [launchwrapper-1.11.jar:?] at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.11.jar:?] at net.minecraftforge.gradle.GradleStartCommon.launch(Unknown Source) [start/:?] at GradleStart.main(Unknown Source) [start/:?] Caused by: java.lang.NullPointerException at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:182) ~[launchwrapper-1.11.jar:?] ... 8 more

I would have thought it was just a broken build, and tried refreshing the project (and I did) - except that, if I remove the coremod from my launch configuration, everything starts fine. So it cannot be a broken build or missing file, it must be something wrong with the coremod.

The launch argument I used is -Dfml.coreMods.load=lotr.common.coremod.LOTRLoadingPlugin

Community content is available under CC-BY-SA unless otherwise noted.